Initial Commit
[packages] / xemacs-packages / sml-mode / sml-mode.spec
1 %define lispdir         %{_datadir}/emacs/site-lisp
2 %define startupfile     %{lispdir}/site-start.el
3
4 Summary:        Emacs mode for editing Standard ML source code
5 Name:           sml-mode
6 Version:        $Name:  $
7 Release:        0.1
8 Group:          Applications/Editors
9 Copyright:      GPL
10 Packager:       Stefan Monnier
11 Source:         ftp://flint.cs.yale.edu/pub/monnier/%{name}/%{name}.tar.gz
12 Buildroot:      %{_tmppath}/%{name}-buildroot
13 BuildPreReq:    emacs >= 20 xemacs >= 21
14 BuildArch:      noarch
15
16 %description
17 SML-MODE is a major Emacs mode for editing Standard ML. It provides
18 syntax highlighting and automatic indentation and comes with sml-proc
19 which allows interaction with an inferior SML interactive loop.
20
21 %prep
22 %setup -q -n %{name}
23
24 %install
25 make install \
26   prefix=%{buildroot}%{_prefix} \
27   infodir=%{buildroot}%{_infodir} \
28   lispdir=%{buildroot}%{lispdir}
29 gzip -9f %{buildroot}%{lispdir}/sml-mode/*.el
30
31 texi2pdf sml-mode.texi
32
33 %post
34 cat >> %{lispdir}/site-start.el <<EOF
35 ;; sml-mode-start
36 ;; This section was automatically generated by rpm
37 (load "sml-mode-startup")
38 ;; End of automatically generated section
39 ;; sml-mode-end
40 EOF
41
42 /sbin/install-info %{_infodir}/sml-mode.info.gz %{_infodir}/dir
43
44 %postun
45 ed -s %{lispdir}/site-start.el <<EOF
46 /^;; sml-mode-start$/,/^;; sml-mode-end$/d
47 wq
48 EOF
49
50 /sbin/install-info --delete %{_infodir}/sml-mode.info.gz %{_infodir}/dir \
51     --section=Emacs \
52     --entry="* SML: (sml-mode).    Editing & Running Standard ML from Emacs"
53
54 %clean
55 rm -rf %{buildroot}
56
57 %files
58 %defattr(-,root,root)
59 %doc BUGS ChangeLog INSTALL NEWS README TODO
60 %doc sml-mode.texi sml-mode.pdf
61 %doc %{_infodir}/*.info*
62 %dir %{lispdir}/%{name}
63 %{lispdir}/%{name}/*.elc
64 %{lispdir}/%{name}/*.el
65 %{lispdir}/%{name}/*.el.*
66
67 %changelog