Initial Commit
[packages] / xemacs-packages / dictionary / debian / rules
1 #!/usr/bin/make -f
2 # Made with the aid of debmake, by Christoph Lameter,
3 # based on the sample debian/rules file for GNU hello by Ian Jackson.
4
5 package=dictionary
6
7 build:
8         $(checkdir)
9         
10         touch build
11
12 clean:
13         $(checkdir)
14         -rm -f build
15         -rm -f `find . -name "*~"`
16         -rm -rf debian/tmp debian/files* core debian/substvars
17
18 binary-indep: checkroot build
19         $(checkdir)
20 # There are no architecture-independent files to be uploaded
21 # generated by this package.  If there were any they would be
22 # made here.
23
24 binary-arch: checkroot build
25         $(checkdir)
26         -rm -rf debian/tmp
27         install -d debian/tmp
28         cd debian/tmp && install -d `cat ../dirs`
29
30         cp dictionary.el connection.el link.el dictionary-init.el \
31                 debian/tmp/usr/share/emacs/site-lisp
32         cp debian/install.debian debian/tmp/usr/lib/emacsen-common/packages/install/dictionary
33         chmod 755 debian/tmp/usr/lib/emacsen-common/packages/install/dictionary
34         cp debian/remove.debian debian/tmp/usr/lib/emacsen-common/packages/remove/dictionary
35         chmod 755 debian/tmp/usr/lib/emacsen-common/packages/remove/dictionary
36         
37         debstd README 
38         dpkg-gencontrol -isp
39         chown -R root.root debian/tmp
40         chmod -R go=rX debian/tmp
41         dpkg --build debian/tmp ..
42
43 define checkdir
44         test -f debian/rules
45 endef
46
47 binary: binary-indep binary-arch
48
49 checkroot:
50         $(checkdir)
51         test root = "`whoami`"
52
53 .PHONY: binary binary-arch binary-indep clean checkroot