Add missing declaration for make_bigz
[sxemacs] / src / Makefile.am
index b173378..5e22ac3 100644 (file)
@@ -58,7 +58,7 @@ ETAGS = $(top_builddir)/lib-src/etags
 TAGS_DEPENDENCIES = $(ETAGS)
 
 bin_PROGRAMS = sxemacs
-bin_SCRIPTS = sxemacs.dmp
+noinst_DATA = sxemacs.dmp
 archlib_DATA = config.values DOC
 
 pdumplibs =
@@ -144,28 +144,26 @@ noinst_LIBRARIES = $(noinst_pdumplibs) $(noinst_nodumplibs)
 acgen_headers = config.h sxe-paths.h
 header_HEADERS = $(acgen_headers)              \
        $(libsxecore_a_headers)                 \
-       emodules-ng.h
+       emodules-ng.h                           \
+       sxe-utils.h
 
 sheader_HEADERS = $(srcdir)/s/*.h
 mheader_HEADERS = $(srcdir)/m/*.h
 
-BUILT_SOURCES = sheap-adjust.h dump-id.c
-EXTRA_DIST = sheap-adjust.h
+BUILT_SOURCES = dump-id.c
+EXTRA_DIST =
 CLEANFILES = core* stage1 stage2 *.stamp $(BUILT_SOURCES) \
        sxemacs.dmp DOC config.values
 
 ## binaries
 sxemacs_SOURCES = $(header_HEADERS)
 ##$(LOCK_OBJ) $(RTC_patch_objs)
-EXTRA_sxemacs_SOURCES = lastfile.c profile.c sheap.c pre-crt0.c ecrt0.c
+EXTRA_sxemacs_SOURCES = lastfile.c profile.c pre-crt0.c ecrt0.c
 sxemacs_CPPFLAGS = $(AM_CPPFLAGS)
 sxemacs_lddep = $(start_files) $(pdumplibs) $(nodumplibs)
 if WITH_PDUMP
 sxemacs_lddep += dump-id.o
 endif
-if BUILD_SHEAP
-sxemacs_lddep += sheap.o
-endif
 if HAVE_SETITIMER
 sxemacs_lddep += profile.o
 endif
@@ -201,7 +199,7 @@ libsxecore_a_headers =                                                      \
        process.h                                                       \
        procimpl.h rangetab.h regex.h semaphore.h seq.h skiplist.h      \
        specifier.h symeval.h symsinit.h syntax.h syscommctrl.h         \
-       sysdep.h sysdir.h sysfile.h sysproc.h syspwd.h                  \
+       sysdep.h sysdir.h sysfile.h sysproc.h syspwd.h sysgrp.h         \
        syssignal.h systime.h syswait.h \
        sxemacs.h
 libsxecore_a_sources =                                                 \
@@ -212,8 +210,7 @@ libsxecore_a_sources =                                                      \
        dynarr.c editfns.c elhash.c emacs.c eval.c dynacat.c            \
        extents.c fileio.c filemode.c fns.c general.c hash.c indent.c   \
        intl.c line-number.c lread.c lstream.c macros.c map.c marker.c  \
-       md5.c                                                           \
-       objects.c opaque.c print.c process.c process-unix.c rangetab.c  \
+       md5.c opaque.c print.c process.c process-unix.c rangetab.c      \
        regex.c search.c semaphore.c seq.c signal.c skiplist.c          \
        strftime.c symbols.c syntax.c sysdep.c undo.c
 libsxecore_a_SOURCES = $(libsxecore_a_headers) $(libsxecore_a_sources)
@@ -256,12 +253,6 @@ RM = rm -f
 CROSSMAKE = (cd $$(dirname $@) && $(MAKE) $(AM_MAKEFLAGS) $$(basename $@))
 
 
-sheap-adjust.h:
-       @echo "Resetting \`src/sheap-adjust.h'."; \
-       (echo "/*       Do not edit this file!" ; \
-        echo " Automatically generated by SXEmacs */" ; \
-        echo "#define SHEAP_ADJUSTMENT 0") > $@
-
 dump-id.c: $(bldlibsrcdir)/make-dump-id
        $(bldlibsrcdir)/make-dump-id
 
@@ -321,7 +312,7 @@ config.values: config.h
 ## one day (when SXE is linked with its own shared libraries) we HAVE to
 ## go that way but at the moment it's okay the way it is
 SXE_SHOW_DUMP = $$($(BITCHENV) $(DESTDIR)$(bindir)/sxemacs -sd)
-SXEDMP_FILENAME=sxemacs-$(old_version)-$(SXE_SHOW_DUMP).dmp
+SXEDMP_FILENAME=sxemacs.dmp
 
 sxemacs.dmp: $(SXEMACS) $(archlib_DATA) $(bldlispdir)/update-elc.stamp
        if test -e "$(bldlispdir)/update-elc.stamp"; then \
@@ -345,14 +336,17 @@ $(bldlispdir)/update-elc.stamp $(bldlispdir)/auto.stamp:
        :
 
 ## improve me, make me (the dump file) independent from the binary
+## because of historical reasons we also delete $(bindir)/sxemacs.dmp here
 install-exec-hook:
        (cd $(DESTDIR)$(bindir) && $(RM) sxemacs.dmp)
+       (cd $(DESTDIR)$(archlibdir) && $(RM) sxemacs.dmp)
        (cd $(abs_builddir); \
        $(BITCHENV) $(DESTDIR)$(bindir)/sxemacs -nd -batch \
                -l $(sxelispdir)/loadup.el \
-               --dump $(DESTDIR)$(bindir)/$(SXEDMP_FILENAME))
-       (cd $(DESTDIR)$(bindir) && \
-               $(LN_S) $(SXEDMP_FILENAME) sxemacs.dmp)
+               --dump $(DESTDIR)$(archlibdir)/$(SXEDMP_FILENAME))
+
+uninstall-hook:
+       (cd $(DESTDIR)$(archlibdir) && $(RM) $(SXEDMP_FILENAME))
 
 
 ## someone who wants to use this actually needs repeat the fuss above