Add logged, but missing change from previous commit.
[sxemacs] / lisp / Makefile.am
index 95e46e1..9806abd 100644 (file)
@@ -15,7 +15,7 @@
 ## General Public License for more details.
 
 ## You should have received a copy of the GNU General Public License
-## along with this program.  If not, see <http://www.gnu.org/licenses/>. 
+## along with this program.  If not, see <http://www.gnu.org/licenses/>.
 
 ## Process this file with automake to produce Makefile.in
 
@@ -56,14 +56,13 @@ ETAGS = $(top_builddir)/lib-src/etags
 TAGS_DEPENDENCIES = $(ETAGS)
 ETAGS_ARGS =
 
-sxepkg_DATA = 
-xepkg_DATA = 
-mulepkg_DATA = 
-sitepkg_DATA = 
+sxepkg_DATA =
+xepkg_DATA =
+mulepkg_DATA =
+sitepkg_DATA =
 
 subdirs = ffi mule term
 
-EXTRA_DIST = ffi/Makefile.in mule/Makefile.in
 nocompile_bldchainels =                                                        \
        build-autoloads.el compile-core.el loadup-el.el loadup.el       \
        site-load.el update-elc.el update-elc-2.el very-early-lisp.el
@@ -77,16 +76,16 @@ corelispels =                                                               \
        build-rpt.el byte-optimize.el bytecomp-runtime.el bytecomp.el   \
        callers-of-rpt.el cl-compat.el cl-extra.el cl-macs.el cl-seq.el \
        cl.el cmdloop.el code-cmds.el code-files.el code-process.el     \
-       coding.el compat.el config.el console.el cus-dep.el             \
-       cus-edit.el cus-face.el cus-file.el cus-load.el cus-start.el    \
-       custom.el derived.el device.el dialog-items.el dialog.el        \
-       disass.el disp-table.el dragdrop.el easy-mmode.el easymenu.el   \
-       emod-utils.el etags.el events.el extents.el faces.el ffi.el     \
-       files-nomule.el files.el fill.el float-sup.el font-lock.el      \
-       font-menu.el font.el fontl-hooks.el format.el frame.el          \
-       glyphs.el gnuserv.el gpm.el gui.el gutter-items.el gutter.el    \
-       help-macro.el help-nomule.el help.el hyper-apropos.el indent.el \
-       info.el isearch-mode.el iso8859-1.el issue-tracker.el           \
+       coding.el compat.el config.el console.el const-aliases.el       \
+       cus-dep.el cus-edit.el cus-face.el cus-file.el cus-load.el      \
+       cus-start.el custom.el derived.el device.el dialog-items.el     \
+       dialog.el disass.el disp-table.el dragdrop.el easy-mmode.el     \
+       easymenu.el emod-utils.el etags.el events.el extents.el         \
+       faces.el ffi.el files-nomule.el files.el fill.el float-sup.el   \
+       font-lock.el font-menu.el font.el fontl-hooks.el format.el      \
+       frame.el glyphs.el gnuserv.el gpm.el gui.el gutter-items.el     \
+       gutter.el help-macro.el help-nomule.el help.el hyper-apropos.el \
+       indent.el info.el isearch-mode.el iso8859-1.el issue-tracker.el \
        itimer-autosave.el itimer.el keydefs.el keymap.el ldap.el       \
        lib-complete.el lisp-initd.el lisp-mnt.el lisp-mode.el lisp.el  \
        list-mode.el loaddefs.el loadhist.el map-ynp.el                 \
@@ -98,12 +97,12 @@ corelispels =                                                               \
        process.el rect.el regexp-opt.el register.el replace.el         \
        resize-minibuffer.el scrollbar.el select.el shadow.el simple.el \
        sound.el specifier.el subr.el symbol-syntax.el symbols.el       \
-       syntax.el text-mode.el text-props.el toolbar-items.el           \
-       toolbar.el tty-init.el undo-stack.el userlock.el version.el     \
-       view-less.el wid-browse.el wid-edit.el widget.el                \
-       window-xemacs.el window.el x-color.el x-compose.el x-faces.el   \
-       x-font-menu.el x-init.el x-iso8859-1.el x-misc.el x-mouse.el    \
-       x-scrollbar.el x-select.el x-win-sun.el x-win-xfree86.el
+        syntax.el text-mode.el text-props.el toolbar-items.el           \
+        toolbar.el tty-init.el undo-stack.el userlock.el version.el     \
+        view-less.el wid-browse.el wid-edit.el widget.el                \
+        window-xemacs.el window.el x-color.el x-compose.el x-faces.el   \
+        x-font-menu.el x-init.el x-iso8859-1.el x-misc.el x-mouse.el    \
+        x-scrollbar.el x-select.el x-win-sun.el x-win-xfree86.el
 
 ffilispels =                                                           \
        ffi/ffi-curl.el ffi/ffi-gcrypt.el ffi/ffi-libc.el               \
@@ -114,7 +113,7 @@ mulelispels =                                                               \
        mule/cyrillic.el mule/english.el mule/ethiopic.el               \
        mule/european.el mule/greek.el mule/hebrew.el mule/japanese.el  \
        mule/kinsoku.el mule/korean.el mule/latin.el mule/misc-lang.el  \
-       mule/mule-category.el mule/ccl.el mule/mule-charset.el          \
+       mule/mule-category.el mule/ccl.el mule/mule-charset.el  \
        mule/mule-cmds.el mule/mule-coding.el mule/mule-help.el         \
        mule/mule-init.el mule/mule-misc.el mule/mule-tty-init.el       \
        mule/mule-x-init.el mule/thai-xtis-chars.el mule/thai-xtis.el   \
@@ -132,15 +131,15 @@ termlispels =                                                             \
 
 builtels =                                                              \
        auto-autoloads.el custom-load.el finder-inf.el                  \
-       custom-defines.el 
+       custom-defines.el
 
 ffibuiltels =                                                           \
-        ffi/auto-autoloads.el ffi/custom-load.el                        \
-        ffi/custom-defines.el
+       ffi/auto-autoloads.el ffi/custom-load.el                        \
+       ffi/custom-defines.el
 
 mulebuiltels =                                                          \
-        mule/auto-autoloads.el mule/custom-load.el                      \
-        mule/custom-defines.el
+       mule/auto-autoloads.el mule/custom-load.el                      \
+       mule/custom-defines.el
 
 
 if HAVE_FFI
@@ -150,7 +149,7 @@ if WITH_MULE
 builtels += $(mulebuiltels)
 endif
 
-nocompile_elfiles = 
+nocompile_elfiles =
 compile_elfiles = $(compile_bldchainels) $(corelispels) $(termlispels)
 if HAVE_FFI
 compile_elfiles += $(ffilispels)
@@ -164,6 +163,8 @@ nobase_dist_lisp_DATA = $(elfiles)
 nobase_lisp_DATA = $(builtels) $(elfiles:.el=.elc) $(builtels:.el=.elc)
 noinst_DATA = auto.stamp update-elc.stamp autoc.stamp
 
+EXTRA_DIST = $(nocompile_bldchainels) $(compile_bldchainels)
+
 BUILT_FILES = auto.stamp update-elc.stamp autoc.stamp
 
 CLEANFILES = core* stage1 stage2 $(builtels) $(builtels:.el=.elc)      \
@@ -264,3 +265,5 @@ auto.stamp: $(SXEMACS) $(compile_elfiles)
 #      @touch $@
 #
 #all: stage1 stage2
+
+.NOTPARALLEL: