Updates/improvements -- riece-xfaceb
[riece] / bootstrap
1 #! /bin/sh
2 # Print a version string.
3 scriptversion=2013-12-05.23; # UTC
4
5 # Bootstrap this package from checked-out sources.
6
7 # Copyright (C) 2003-2014 Free Software Foundation, Inc.
8
9 # This program is free software: you can redistribute it and/or modify
10 # it under the terms of the GNU General Public License as published by
11 # the Free Software Foundation, either version 3 of the License, or
12 # (at your option) any later version.
13
14 # This program is distributed in the hope that it will be useful,
15 # but WITHOUT ANY WARRANTY; without even the implied warranty of
16 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
17 # GNU General Public License for more details.
18
19 # You should have received a copy of the GNU General Public License
20 # along with this program.  If not, see <http://www.gnu.org/licenses/>.
21
22 # Originally written by Paul Eggert.  The canonical version of this
23 # script is maintained as build-aux/bootstrap in gnulib, however, to
24 # be useful to your project, you should place a copy of it under
25 # version control in the top-level directory of your project.  The
26 # intent is that all customization can be done with a bootstrap.conf
27 # file also maintained in your version control; gnulib comes with a
28 # template build-aux/bootstrap.conf to get you started.
29
30 # Please report bugs or propose patches to bug-gnulib@gnu.org.
31
32 nl='
33 '
34
35 # Ensure file names are sorted consistently across platforms.
36 LC_ALL=C
37 export LC_ALL
38
39 # Ensure that CDPATH is not set.  Otherwise, the output from cd
40 # would cause trouble in at least one use below.
41 (unset CDPATH) >/dev/null 2>&1 && unset CDPATH
42
43 local_gl_dir=gl
44
45 me=$0
46
47 usage() {
48   cat <<EOF
49 Usage: $me [OPTION]...
50 Bootstrap this package from the checked-out sources.
51
52 Options:
53  --gnulib-srcdir=DIRNAME  specify the local directory where gnulib
54                           sources reside.  Use this if you already
55                           have gnulib sources on your machine, and
56                           do not want to waste your bandwidth downloading
57                           them again.  Defaults to \$GNULIB_SRCDIR
58  --bootstrap-sync         if this bootstrap script is not identical to
59                           the version in the local gnulib sources,
60                           update this script, and then restart it with
61                           /bin/sh or the shell \$CONFIG_SHELL
62  --no-bootstrap-sync      do not check whether bootstrap is out of sync
63  --copy                   copy files instead of creating symbolic links
64  --force                  attempt to bootstrap even if the sources seem
65                           not to have been checked out
66  --no-git                 do not use git to update gnulib.  Requires that
67                           --gnulib-srcdir point to a correct gnulib snapshot
68  --skip-po                do not download po files
69
70 If the file $me.conf exists in the same directory as this script, its
71 contents are read as shell variables to configure the bootstrap.
72
73 For build prerequisites, environment variables like \$AUTOCONF and \$AMTAR
74 are honored.
75
76 Running without arguments will suffice in most cases.
77 EOF
78 }
79
80 # warnf_ FORMAT-STRING ARG1...
81 warnf_ ()
82 {
83   warnf_format_=$1
84   shift
85   nl='
86 '
87   case $* in
88     *$nl*) me_=$(printf "$me"|tr "$nl|" '??')
89        printf "$warnf_format_" "$@" | sed "s|^|$me_: |" ;;
90     *) printf "$me: $warnf_format_" "$@" ;;
91   esac >&2
92 }
93
94 # warn_ WORD1...
95 warn_ ()
96 {
97   # If IFS does not start with ' ', set it and emit the warning in a subshell.
98   case $IFS in
99     ' '*) warnf_ '%s\n' "$*";;
100     *)    (IFS=' '; warn_ "$@");;
101   esac
102 }
103
104 # die WORD1...
105 die() { warn_ "$@"; exit 1; }
106
107 # Configuration.
108
109 # Name of the Makefile.am
110 gnulib_mk=gnulib.mk
111
112 # List of gnulib modules needed.
113 gnulib_modules=
114
115 # Any gnulib files needed that are not in modules.
116 gnulib_files=
117
118 : ${AUTOPOINT=autopoint}
119 : ${AUTORECONF=autoreconf}
120
121 # A function to be called right after gnulib-tool is run.
122 # Override it via your own definition in bootstrap.conf.
123 bootstrap_post_import_hook() { :; }
124
125 # A function to be called after everything else in this script.
126 # Override it via your own definition in bootstrap.conf.
127 bootstrap_epilogue() { :; }
128
129 # The command to download all .po files for a specified domain into
130 # a specified directory.  Fill in the first %s is the domain name, and
131 # the second with the destination directory.  Use rsync's -L and -r
132 # options because the latest/%s directory and the .po files within are
133 # all symlinks.
134 po_download_command_format=\
135 "rsync --delete --exclude '*.s1' -Lrtvz \
136  'translationproject.org::tp/latest/%s/' '%s'"
137
138 # Fallback for downloading .po files (if rsync fails).
139 po_download_command_format2=\
140 "wget --mirror -nd -q -np -A.po -P '%s' \
141  http://translationproject.org/latest/%s/"
142
143 # Prefer a non-empty tarname (4th argument of AC_INIT if given), else
144 # fall back to the package name (1st argument with munging)
145 extract_package_name='
146   /^AC_INIT(\[*/{
147      s///
148      /^[^,]*,[^,]*,[^,]*,[ []*\([^][ ,)]\)/{
149        s//\1/
150        s/[],)].*//
151        p
152        q
153      }
154      s/[],)].*//
155      s/^GNU //
156      y/ABCDEFGHIJKLMNOPQRSTUVWXYZ/abcdefghijklmnopqrstuvwxyz/
157      s/[^abcdefghijklmnopqrstuvwxyz0123456789_]/-/g
158      p
159   }
160 '
161 package=$(sed -n "$extract_package_name" configure.ac) \
162   || die 'cannot find package name in configure.ac'
163 gnulib_name=lib$package
164
165 build_aux=build-aux
166 source_base=lib
167 m4_base=m4
168 doc_base=doc
169 tests_base=tests
170 gnulib_extra_files=''
171
172 # Additional gnulib-tool options to use.  Use "\newline" to break lines.
173 gnulib_tool_option_extras=
174
175 # Other locale categories that need message catalogs.
176 EXTRA_LOCALE_CATEGORIES=
177
178 # Additional xgettext options to use.  Use "\\\newline" to break lines.
179 XGETTEXT_OPTIONS='\\\
180  --flag=_:1:pass-c-format\\\
181  --flag=N_:1:pass-c-format\\\
182  --flag=error:3:c-format --flag=error_at_line:5:c-format\\\
183 '
184
185 # Package bug report address and copyright holder for gettext files
186 COPYRIGHT_HOLDER='Free Software Foundation, Inc.'
187 MSGID_BUGS_ADDRESS=bug-$package@gnu.org
188
189 # Files we don't want to import.
190 excluded_files=
191
192 # File that should exist in the top directory of a checked out hierarchy,
193 # but not in a distribution tarball.
194 checkout_only_file=README-hacking
195
196 # Whether to use copies instead of symlinks.
197 copy=false
198
199 # Set this to '.cvsignore .gitignore' in bootstrap.conf if you want
200 # those files to be generated in directories like lib/, m4/, and po/.
201 # Or set it to 'auto' to make this script select which to use based
202 # on which version control system (if any) is used in the source directory.
203 vc_ignore=auto
204
205 # Set this to true in bootstrap.conf to enable --bootstrap-sync by
206 # default.
207 bootstrap_sync=false
208
209 # Use git to update gnulib sources
210 use_git=true
211
212 check_exists() {
213   ($1 --version </dev/null) >/dev/null 2>&1
214   test $? -lt 126
215 }
216
217 # find_tool ENVVAR NAMES...
218 # -------------------------
219 # Search for a required program.  Use the value of ENVVAR, if set,
220 # otherwise find the first of the NAMES that can be run.
221 # If found, set ENVVAR to the program name, die otherwise.
222 #
223 # FIXME: code duplication, see also gnu-web-doc-update.
224 find_tool ()
225 {
226   find_tool_envvar=$1
227   shift
228   find_tool_names=$@
229   eval "find_tool_res=\$$find_tool_envvar"
230   if test x"$find_tool_res" = x; then
231     for i; do
232       if check_exists $i; then
233         find_tool_res=$i
234         break
235       fi
236     done
237   fi
238   if test x"$find_tool_res" = x; then
239     warn_ "one of these is required: $find_tool_names;"
240     die   "alternatively set $find_tool_envvar to a compatible tool"
241   fi
242   eval "$find_tool_envvar=\$find_tool_res"
243   eval "export $find_tool_envvar"
244 }
245
246 # Override the default configuration, if necessary.
247 # Make sure that bootstrap.conf is sourced from the current directory
248 # if we were invoked as "sh bootstrap".
249 case "$0" in
250   */*) test -r "$0.conf" && . "$0.conf" ;;
251   *) test -r "$0.conf" && . ./"$0.conf" ;;
252 esac
253
254 # Extra files from gnulib, which override files from other sources.
255 test -z "${gnulib_extra_files}" && \
256   gnulib_extra_files="
257         build-aux/install-sh
258         build-aux/mdate-sh
259         build-aux/texinfo.tex
260         build-aux/depcomp
261         build-aux/config.guess
262         build-aux/config.sub
263         doc/INSTALL
264 "
265
266 if test "$vc_ignore" = auto; then
267   vc_ignore=
268   test -d .git && vc_ignore=.gitignore
269   test -d CVS && vc_ignore="$vc_ignore .cvsignore"
270 fi
271
272 # Translate configuration into internal form.
273
274 # Parse options.
275
276 for option
277 do
278   case $option in
279   --help)
280     usage
281     exit;;
282   --gnulib-srcdir=*)
283     GNULIB_SRCDIR=${option#--gnulib-srcdir=};;
284   --skip-po)
285     SKIP_PO=t;;
286   --force)
287     checkout_only_file=;;
288   --copy)
289     copy=true;;
290   --bootstrap-sync)
291     bootstrap_sync=true;;
292   --no-bootstrap-sync)
293     bootstrap_sync=false;;
294   --no-git)
295     use_git=false;;
296   *)
297     die "$option: unknown option";;
298   esac
299 done
300
301 $use_git || test -d "$GNULIB_SRCDIR" \
302   || die "Error: --no-git requires --gnulib-srcdir"
303
304 if test -n "$checkout_only_file" && test ! -r "$checkout_only_file"; then
305   die "Bootstrapping from a non-checked-out distribution is risky."
306 fi
307
308 # Strip blank and comment lines to leave significant entries.
309 gitignore_entries() {
310   sed '/^#/d; /^$/d' "$@"
311 }
312
313 # If $STR is not already on a line by itself in $FILE, insert it at the start.
314 # Entries are inserted at the start of the ignore list to ensure existing
315 # entries starting with ! are not overridden.  Such entries support
316 # whitelisting exceptions after a more generic blacklist pattern.
317 insert_if_absent() {
318   file=$1
319   str=$2
320   test -f $file || touch $file
321   test -r $file || die "Error: failed to read ignore file: $file"
322   duplicate_entries=$(gitignore_entries $file | sort | uniq -d)
323   if [ "$duplicate_entries" ] ; then
324     die "Error: Duplicate entries in $file: " $duplicate_entries
325   fi
326   linesold=$(gitignore_entries $file | wc -l)
327   linesnew=$( { echo "$str"; cat $file; } | gitignore_entries | sort -u | wc -l)
328   if [ $linesold != $linesnew ] ; then
329     { echo "$str" | cat - $file > $file.bak && mv $file.bak $file; } \
330       || die "insert_if_absent $file $str: failed"
331   fi
332 }
333
334 # Adjust $PATTERN for $VC_IGNORE_FILE and insert it with
335 # insert_if_absent.
336 insert_vc_ignore() {
337   vc_ignore_file="$1"
338   pattern="$2"
339   case $vc_ignore_file in
340   *.gitignore)
341     # A .gitignore entry that does not start with '/' applies
342     # recursively to subdirectories, so prepend '/' to every
343     # .gitignore entry.
344     pattern=$(echo "$pattern" | sed s,^,/,);;
345   esac
346   insert_if_absent "$vc_ignore_file" "$pattern"
347 }
348
349 # Die if there is no AC_CONFIG_AUX_DIR($build_aux) line in configure.ac.
350 found_aux_dir=no
351 grep '^[         ]*AC_CONFIG_AUX_DIR(\['"$build_aux"'\])' configure.ac \
352     >/dev/null && found_aux_dir=yes
353 grep '^[         ]*AC_CONFIG_AUX_DIR('"$build_aux"')' configure.ac \
354     >/dev/null && found_aux_dir=yes
355 test $found_aux_dir = yes \
356   || die "configure.ac lacks 'AC_CONFIG_AUX_DIR([$build_aux])'; add it"
357
358 # If $build_aux doesn't exist, create it now, otherwise some bits
359 # below will malfunction.  If creating it, also mark it as ignored.
360 if test ! -d $build_aux; then
361   mkdir $build_aux
362   for dot_ig in x $vc_ignore; do
363     test $dot_ig = x && continue
364     insert_vc_ignore $dot_ig $build_aux
365   done
366 fi
367
368 # Note this deviates from the version comparison in automake
369 # in that it treats 1.5 < 1.5.0, and treats 1.4.4a < 1.4-p3a
370 # but this should suffice as we won't be specifying old
371 # version formats or redundant trailing .0 in bootstrap.conf.
372 # If we did want full compatibility then we should probably
373 # use m4_version_compare from autoconf.
374 sort_ver() { # sort -V is not generally available
375   ver1="$1"
376   ver2="$2"
377
378   # split on '.' and compare each component
379   i=1
380   while : ; do
381     p1=$(echo "$ver1" | cut -d. -f$i)
382     p2=$(echo "$ver2" | cut -d. -f$i)
383     if [ ! "$p1" ]; then
384       echo "$1 $2"
385       break
386     elif [ ! "$p2" ]; then
387       echo "$2 $1"
388       break
389     elif [ ! "$p1" = "$p2" ]; then
390       if [ "$p1" -gt "$p2" ] 2>/dev/null; then # numeric comparison
391         echo "$2 $1"
392       elif [ "$p2" -gt "$p1" ] 2>/dev/null; then # numeric comparison
393         echo "$1 $2"
394       else # numeric, then lexicographic comparison
395         lp=$(printf "$p1\n$p2\n" | LANG=C sort -n | tail -n1)
396         if [ "$lp" = "$p2" ]; then
397           echo "$1 $2"
398         else
399           echo "$2 $1"
400         fi
401       fi
402       break
403     fi
404     i=$(($i+1))
405   done
406 }
407
408 get_version() {
409   app=$1
410
411   $app --version >/dev/null 2>&1 || return 1
412
413   $app --version 2>&1 |
414   sed -n '# Move version to start of line.
415           s/.*[v ]\([0-9]\)/\1/
416
417           # Skip lines that do not start with version.
418           /^[0-9]/!d
419
420           # Remove characters after the version.
421           s/[^.a-z0-9-].*//
422
423           # The first component must be digits only.
424           s/^\([0-9]*\)[a-z-].*/\1/
425
426           #the following essentially does s/5.005/5.5/
427           s/\.0*\([1-9]\)/.\1/g
428           p
429           q'
430 }
431
432 check_versions() {
433   ret=0
434
435   while read app req_ver; do
436     # We only need libtoolize from the libtool package.
437     if test "$app" = libtool; then
438       app=libtoolize
439     fi
440     # Exempt git if --no-git is in effect.
441     if test "$app" = git; then
442       $use_git || continue
443     fi
444     # Honor $APP variables ($TAR, $AUTOCONF, etc.)
445     appvar=$(echo $app | LC_ALL=C tr '[a-z]-' '[A-Z]_')
446     test "$appvar" = TAR && appvar=AMTAR
447     case $appvar in
448         GZIP) ;; # Do not use $GZIP:  it contains gzip options.
449         *) eval "app=\${$appvar-$app}" ;;
450     esac
451
452     # Handle the still-experimental Automake-NG programs specially.
453     # They remain named as the mainstream Automake programs ("automake",
454     # and "aclocal") to avoid gratuitous incompatibilities with
455     # pre-existing usages (by, say, autoreconf, or custom autogen.sh
456     # scripts), but correctly identify themselves (as being part of
457     # "GNU automake-ng") when asked their version.
458     case $app in
459       automake-ng|aclocal-ng)
460         app=${app%-ng}
461         ($app --version | grep '(GNU automake-ng)') >/dev/null 2>&1 || {
462           warn_ "Error: '$app' not found or not from Automake-NG"
463           ret=1
464           continue
465         } ;;
466     esac
467     if [ "$req_ver" = "-" ]; then
468       # Merely require app to exist; not all prereq apps are well-behaved
469       # so we have to rely on $? rather than get_version.
470       if ! check_exists $app; then
471         warn_ "Error: '$app' not found"
472         ret=1
473       fi
474     else
475       # Require app to produce a new enough version string.
476       inst_ver=$(get_version $app)
477       if [ ! "$inst_ver" ]; then
478         warn_ "Error: '$app' not found"
479         ret=1
480       else
481         latest_ver=$(sort_ver $req_ver $inst_ver | cut -d' ' -f2)
482         if [ ! "$latest_ver" = "$inst_ver" ]; then
483           warnf_ '%s\n'                                        \
484               "Error: '$app' version == $inst_ver is too old"  \
485               "       '$app' version >= $req_ver is required"
486           ret=1
487         fi
488       fi
489     fi
490   done
491
492   return $ret
493 }
494
495 print_versions() {
496   echo "Program    Min_version"
497   echo "----------------------"
498   printf %s "$buildreq"
499   echo "----------------------"
500   # can't depend on column -t
501 }
502
503 # Find sha1sum, named gsha1sum on MacPorts, shasum on Mac OS X 10.6.
504 # Also find the compatible sha1 utility on the BSDs
505 if test x"$SKIP_PO" = x; then
506   find_tool SHA1SUM sha1sum gsha1sum shasum sha1
507 fi
508
509 use_libtool=0
510 # We'd like to use grep -E, to see if any of LT_INIT,
511 # AC_PROG_LIBTOOL, AM_PROG_LIBTOOL is used in configure.ac,
512 # but that's not portable enough (e.g., for Solaris).
513 grep '^[         ]*A[CM]_PROG_LIBTOOL' configure.ac >/dev/null \
514   && use_libtool=1
515 grep '^[         ]*LT_INIT' configure.ac >/dev/null \
516   && use_libtool=1
517 if test $use_libtool = 1; then
518   find_tool LIBTOOLIZE glibtoolize libtoolize
519 fi
520
521 # gnulib-tool requires at least automake and autoconf.
522 # If either is not listed, add it (with minimum version) as a prerequisite.
523 case $buildreq in
524   *automake*) ;;
525   *) buildreq="automake 1.9
526 $buildreq" ;;
527 esac
528 case $buildreq in
529   *autoconf*) ;;
530   *) buildreq="autoconf 2.59
531 $buildreq" ;;
532 esac
533
534 # When we can deduce that gnulib-tool will require patch,
535 # and when patch is not already listed as a prerequisite, add it, too.
536 if test -d "$local_gl_dir" \
537     && ! find "$local_gl_dir" -name '*.diff' -exec false {} +; then
538   case $buildreq in
539     *patch*) ;;
540     *) buildreq="patch -
541 $buildreq" ;;
542   esac
543 fi
544
545 if ! printf "$buildreq" | check_versions; then
546   echo >&2
547   if test -f README-prereq; then
548     die "See README-prereq for how to get the prerequisite programs"
549   else
550     die "Please install the prerequisite programs"
551   fi
552 fi
553
554 # Warn the user if autom4te appears to be broken; this causes known
555 # issues with at least gettext 0.18.3.
556 probe=$(echo 'm4_quote([hi])' | autom4te -l M4sugar -t 'm4_quote:$%' -)
557 if test "x$probe" != xhi; then
558   warn_ "WARNING: your autom4te wrapper eats stdin;"
559   warn_ "if bootstrap fails, consider upgrading your autotools"
560 fi
561
562 echo "$0: Bootstrapping from checked-out $package sources..."
563
564 # See if we can use gnulib's git-merge-changelog merge driver.
565 if $use_git && test -d .git && check_exists git; then
566   if git config merge.merge-changelog.driver >/dev/null ; then
567     :
568   elif check_exists git-merge-changelog; then
569     echo "$0: initializing git-merge-changelog driver"
570     git config merge.merge-changelog.name 'GNU-style ChangeLog merge driver'
571     git config merge.merge-changelog.driver 'git-merge-changelog %O %A %B'
572   else
573     echo "$0: consider installing git-merge-changelog from gnulib"
574   fi
575 fi
576
577
578 cleanup_gnulib() {
579   status=$?
580   rm -fr "$gnulib_path"
581   exit $status
582 }
583
584 git_modules_config () {
585   test -f .gitmodules && git config --file .gitmodules "$@"
586 }
587
588 if $use_git; then
589   gnulib_path=$(git_modules_config submodule.gnulib.path)
590   test -z "$gnulib_path" && gnulib_path=gnulib
591 fi
592
593 # Get gnulib files.  Populate $GNULIB_SRCDIR, possibly updating a
594 # submodule, for use in the rest of the script.
595
596 case ${GNULIB_SRCDIR--} in
597 -)
598   # Note that $use_git is necessarily true in this case.
599   if git_modules_config submodule.gnulib.url >/dev/null; then
600     echo "$0: getting gnulib files..."
601     git submodule init || exit $?
602     git submodule update || exit $?
603
604   elif [ ! -d "$gnulib_path" ]; then
605     echo "$0: getting gnulib files..."
606
607     trap cleanup_gnulib 1 2 13 15
608
609     shallow=
610     git clone -h 2>&1 | grep -- --depth > /dev/null && shallow='--depth 2'
611     git clone $shallow git://git.sv.gnu.org/gnulib "$gnulib_path" ||
612       cleanup_gnulib
613
614     trap - 1 2 13 15
615   fi
616   GNULIB_SRCDIR=$gnulib_path
617   ;;
618 *)
619   # Use GNULIB_SRCDIR directly or as a reference.
620   if $use_git && test -d "$GNULIB_SRCDIR"/.git && \
621         git_modules_config submodule.gnulib.url >/dev/null; then
622     echo "$0: getting gnulib files..."
623     if git submodule -h|grep -- --reference > /dev/null; then
624       # Prefer the one-liner available in git 1.6.4 or newer.
625       git submodule update --init --reference "$GNULIB_SRCDIR" \
626         "$gnulib_path" || exit $?
627     else
628       # This fallback allows at least git 1.5.5.
629       if test -f "$gnulib_path"/gnulib-tool; then
630         # Since file already exists, assume submodule init already complete.
631         git submodule update || exit $?
632       else
633         # Older git can't clone into an empty directory.
634         rmdir "$gnulib_path" 2>/dev/null
635         git clone --reference "$GNULIB_SRCDIR" \
636           "$(git_modules_config submodule.gnulib.url)" "$gnulib_path" \
637           && git submodule init && git submodule update \
638           || exit $?
639       fi
640     fi
641     GNULIB_SRCDIR=$gnulib_path
642   fi
643   ;;
644 esac
645
646 # $GNULIB_SRCDIR now points to the version of gnulib to use, and
647 # we no longer need to use git or $gnulib_path below here.
648
649 if $bootstrap_sync; then
650   cmp -s "$0" "$GNULIB_SRCDIR/build-aux/bootstrap" || {
651     echo "$0: updating bootstrap and restarting..."
652     case $(sh -c 'echo "$1"' -- a) in
653       a) ignored=--;;
654       *) ignored=ignored;;
655     esac
656     exec sh -c \
657       'cp "$1" "$2" && shift && exec "${CONFIG_SHELL-/bin/sh}" "$@"' \
658       $ignored "$GNULIB_SRCDIR/build-aux/bootstrap" \
659       "$0" "$@" --no-bootstrap-sync
660   }
661 fi
662
663 gnulib_tool=$GNULIB_SRCDIR/gnulib-tool
664 <$gnulib_tool || exit $?
665
666 # Get translations.
667
668 download_po_files() {
669   subdir=$1
670   domain=$2
671   echo "$me: getting translations into $subdir for $domain..."
672   cmd=$(printf "$po_download_command_format" "$domain" "$subdir")
673   eval "$cmd" && return
674   # Fallback to HTTP.
675   cmd=$(printf "$po_download_command_format2" "$subdir" "$domain")
676   eval "$cmd"
677 }
678
679 # Mirror .po files to $po_dir/.reference and copy only the new
680 # or modified ones into $po_dir.  Also update $po_dir/LINGUAS.
681 # Note po files that exist locally only are left in $po_dir but will
682 # not be included in LINGUAS and hence will not be distributed.
683 update_po_files() {
684   # Directory containing primary .po files.
685   # Overwrite them only when we're sure a .po file is new.
686   po_dir=$1
687   domain=$2
688
689   # Mirror *.po files into this dir.
690   # Usually contains *.s1 checksum files.
691   ref_po_dir="$po_dir/.reference"
692
693   test -d $ref_po_dir || mkdir $ref_po_dir || return
694   download_po_files $ref_po_dir $domain \
695     && ls "$ref_po_dir"/*.po 2>/dev/null |
696       sed 's|.*/||; s|\.po$||' > "$po_dir/LINGUAS" || return
697
698   langs=$(cd $ref_po_dir && echo *.po | sed 's/\.po//g')
699   test "$langs" = '*' && langs=x
700   for po in $langs; do
701     case $po in x) continue;; esac
702     new_po="$ref_po_dir/$po.po"
703     cksum_file="$ref_po_dir/$po.s1"
704     if ! test -f "$cksum_file" ||
705         ! test -f "$po_dir/$po.po" ||
706         ! $SHA1SUM -c "$cksum_file" < "$new_po" > /dev/null 2>&1; then
707       echo "$me: updated $po_dir/$po.po..."
708       cp "$new_po" "$po_dir/$po.po" \
709           && $SHA1SUM < "$new_po" > "$cksum_file" || return
710     fi
711   done
712 }
713
714 case $SKIP_PO in
715 '')
716   if test -d po; then
717     update_po_files po $package || exit
718   fi
719
720   if test -d runtime-po; then
721     update_po_files runtime-po $package-runtime || exit
722   fi;;
723 esac
724
725 symlink_to_dir()
726 {
727   src=$1/$2
728   dst=${3-$2}
729
730   test -f "$src" && {
731
732     # If the destination directory doesn't exist, create it.
733     # This is required at least for "lib/uniwidth/cjk.h".
734     dst_dir=$(dirname "$dst")
735     if ! test -d "$dst_dir"; then
736       mkdir -p "$dst_dir"
737
738       # If we've just created a directory like lib/uniwidth,
739       # tell version control system(s) it's ignorable.
740       # FIXME: for now, this does only one level
741       parent=$(dirname "$dst_dir")
742       for dot_ig in x $vc_ignore; do
743         test $dot_ig = x && continue
744         ig=$parent/$dot_ig
745         insert_vc_ignore $ig "${dst_dir##*/}"
746       done
747     fi
748
749     if $copy; then
750       {
751         test ! -h "$dst" || {
752           echo "$me: rm -f $dst" &&
753           rm -f "$dst"
754         }
755       } &&
756       test -f "$dst" &&
757       cmp -s "$src" "$dst" || {
758         echo "$me: cp -fp $src $dst" &&
759         cp -fp "$src" "$dst"
760       }
761     else
762       # Leave any existing symlink alone, if it already points to the source,
763       # so that broken build tools that care about symlink times
764       # aren't confused into doing unnecessary builds.  Conversely, if the
765       # existing symlink's time stamp is older than the source, make it afresh,
766       # so that broken tools aren't confused into skipping needed builds.  See
767       # <http://lists.gnu.org/archive/html/bug-gnulib/2011-05/msg00326.html>.
768       test -h "$dst" &&
769       src_ls=$(ls -diL "$src" 2>/dev/null) && set $src_ls && src_i=$1 &&
770       dst_ls=$(ls -diL "$dst" 2>/dev/null) && set $dst_ls && dst_i=$1 &&
771       test "$src_i" = "$dst_i" &&
772       both_ls=$(ls -dt "$src" "$dst") &&
773       test "X$both_ls" = "X$dst$nl$src" || {
774         dot_dots=
775         case $src in
776         /*) ;;
777         *)
778           case /$dst/ in
779           *//* | */../* | */./* | /*/*/*/*/*/)
780              die "invalid symlink calculation: $src -> $dst";;
781           /*/*/*/*/)    dot_dots=../../../;;
782           /*/*/*/)      dot_dots=../../;;
783           /*/*/)        dot_dots=../;;
784           esac;;
785         esac
786
787         echo "$me: ln -fs $dot_dots$src $dst" &&
788         ln -fs "$dot_dots$src" "$dst"
789       }
790     fi
791   }
792 }
793
794 version_controlled_file() {
795   parent=$1
796   file=$2
797   if test -d .git; then
798     git rm -n "$file" > /dev/null 2>&1
799   elif test -d .svn; then
800     svn log -r HEAD "$file" > /dev/null 2>&1
801   elif test -d CVS; then
802     grep -F "/${file##*/}/" "$parent/CVS/Entries" 2>/dev/null |
803              grep '^/[^/]*/[0-9]' > /dev/null
804   else
805     warn_ "no version control for $file?"
806     false
807   fi
808 }
809
810 # NOTE: we have to be careful to run both autopoint and libtoolize
811 # before gnulib-tool, since gnulib-tool is likely to provide newer
812 # versions of files "installed" by these two programs.
813 # Then, *after* gnulib-tool (see below), we have to be careful to
814 # run autoreconf in such a way that it does not run either of these
815 # two just-pre-run programs.
816
817 # Import from gettext.
818 with_gettext=yes
819 grep '^[         ]*AM_GNU_GETTEXT_VERSION(' configure.ac >/dev/null || \
820     with_gettext=no
821
822 if test $with_gettext = yes || test $use_libtool = 1; then
823
824   tempbase=.bootstrap$$
825   trap "rm -f $tempbase.0 $tempbase.1" 1 2 13 15
826
827   > $tempbase.0 > $tempbase.1 &&
828   find . ! -type d -print | sort > $tempbase.0 || exit
829
830   if test $with_gettext = yes; then
831     # Released autopoint has the tendency to install macros that have been
832     # obsoleted in current gnulib, so run this before gnulib-tool.
833     echo "$0: $AUTOPOINT --force"
834     $AUTOPOINT --force || exit
835   fi
836
837   # Autoreconf runs aclocal before libtoolize, which causes spurious
838   # warnings if the initial aclocal is confused by the libtoolized
839   # (or worse out-of-date) macro directory.
840   # libtoolize 1.9b added the --install option; but we support back
841   # to libtoolize 1.5.22, where the install action was default.
842   if test $use_libtool = 1; then
843     install=
844     case $($LIBTOOLIZE --help) in
845       *--install*) install=--install ;;
846     esac
847     echo "running: $LIBTOOLIZE $install --copy"
848     $LIBTOOLIZE $install --copy
849   fi
850
851   find . ! -type d -print | sort >$tempbase.1
852   old_IFS=$IFS
853   IFS=$nl
854   for file in $(comm -13 $tempbase.0 $tempbase.1); do
855     IFS=$old_IFS
856     parent=${file%/*}
857     version_controlled_file "$parent" "$file" || {
858       for dot_ig in x $vc_ignore; do
859         test $dot_ig = x && continue
860         ig=$parent/$dot_ig
861         insert_vc_ignore "$ig" "${file##*/}"
862       done
863     }
864   done
865   IFS=$old_IFS
866
867   rm -f $tempbase.0 $tempbase.1
868   trap - 1 2 13 15
869 fi
870
871 # Import from gnulib.
872
873 gnulib_tool_options="\
874  --import\
875  --no-changelog\
876  --aux-dir $build_aux\
877  --doc-base $doc_base\
878  --lib $gnulib_name\
879  --m4-base $m4_base/\
880  --source-base $source_base/\
881  --tests-base $tests_base\
882  --local-dir $local_gl_dir\
883  $gnulib_tool_option_extras\
884 "
885 if test $use_libtool = 1; then
886   case "$gnulib_tool_options " in
887     *' --libtool '*) ;;
888     *) gnulib_tool_options="$gnulib_tool_options --libtool" ;;
889   esac
890 fi
891 echo "$0: $gnulib_tool $gnulib_tool_options --import ..."
892 $gnulib_tool $gnulib_tool_options --import $gnulib_modules &&
893
894 for file in $gnulib_files; do
895   symlink_to_dir "$GNULIB_SRCDIR" $file \
896     || die "failed to symlink $file"
897 done
898
899 bootstrap_post_import_hook \
900   || die "bootstrap_post_import_hook failed"
901
902 # Remove any dangling symlink matching "*.m4" or "*.[ch]" in some
903 # gnulib-populated directories.  Such .m4 files would cause aclocal to fail.
904 # The following requires GNU find 4.2.3 or newer.  Considering the usual
905 # portability constraints of this script, that may seem a very demanding
906 # requirement, but it should be ok.  Ignore any failure, which is fine,
907 # since this is only a convenience to help developers avoid the relatively
908 # unusual case in which a symlinked-to .m4 file is git-removed from gnulib
909 # between successive runs of this script.
910 find "$m4_base" "$source_base" \
911   -depth \( -name '*.m4' -o -name '*.[ch]' \) \
912   -type l -xtype l -delete > /dev/null 2>&1
913
914 # Invoke autoreconf with --force --install to ensure upgrades of tools
915 # such as ylwrap.
916 AUTORECONFFLAGS="--verbose --install --force -I $m4_base $ACLOCAL_FLAGS"
917
918 # Some systems (RHEL 5) are using ancient autotools, for which the
919 # --no-recursive option had not been invented.  Detect that lack and
920 # omit the option when it's not supported.  FIXME in 2017: remove this
921 # hack when RHEL 5 autotools are updated, or when they become irrelevant.
922 case $($AUTORECONF --help) in
923   *--no-recursive*) AUTORECONFFLAGS="$AUTORECONFFLAGS --no-recursive";;
924 esac
925
926 # Tell autoreconf not to invoke autopoint or libtoolize; they were run above.
927 echo "running: AUTOPOINT=true LIBTOOLIZE=true $AUTORECONF $AUTORECONFFLAGS"
928 AUTOPOINT=true LIBTOOLIZE=true $AUTORECONF $AUTORECONFFLAGS \
929   || die "autoreconf failed"
930
931 # Get some extra files from gnulib, overriding existing files.
932 for file in $gnulib_extra_files; do
933   case $file in
934   */INSTALL) dst=INSTALL;;
935   build-aux/*) dst=$build_aux/${file#build-aux/};;
936   *) dst=$file;;
937   esac
938   symlink_to_dir "$GNULIB_SRCDIR" $file $dst \
939     || die "failed to symlink $file"
940 done
941
942 if test $with_gettext = yes; then
943   # Create gettext configuration.
944   echo "$0: Creating po/Makevars from po/Makevars.template ..."
945   rm -f po/Makevars
946   sed '
947     /^EXTRA_LOCALE_CATEGORIES *=/s/=.*/= '"$EXTRA_LOCALE_CATEGORIES"'/
948     /^COPYRIGHT_HOLDER *=/s/=.*/= '"$COPYRIGHT_HOLDER"'/
949     /^MSGID_BUGS_ADDRESS *=/s|=.*|= '"$MSGID_BUGS_ADDRESS"'|
950     /^XGETTEXT_OPTIONS *=/{
951       s/$/ \\/
952       a\
953           '"$XGETTEXT_OPTIONS"' $${end_of_xgettext_options+}
954     }
955   ' po/Makevars.template >po/Makevars \
956     || die 'cannot generate po/Makevars'
957
958   # If the 'gettext' module is in use, grab the latest Makefile.in.in.
959   # If only the 'gettext-h' module is in use, assume autopoint already
960   # put the correct version of this file into place.
961   case $gnulib_modules in
962   *gettext-h*) ;;
963   *gettext*)
964     cp $GNULIB_SRCDIR/build-aux/po/Makefile.in.in po/Makefile.in.in \
965       || die "cannot create po/Makefile.in.in"
966     ;;
967   esac
968
969   if test -d runtime-po; then
970     # Similarly for runtime-po/Makevars, but not quite the same.
971     rm -f runtime-po/Makevars
972     sed '
973       /^DOMAIN *=.*/s/=.*/= '"$package"'-runtime/
974       /^subdir *=.*/s/=.*/= runtime-po/
975       /^MSGID_BUGS_ADDRESS *=/s/=.*/= bug-'"$package"'@gnu.org/
976       /^XGETTEXT_OPTIONS *=/{
977         s/$/ \\/
978         a\
979             '"$XGETTEXT_OPTIONS_RUNTIME"' $${end_of_xgettext_options+}
980       }
981     ' po/Makevars.template >runtime-po/Makevars \
982     || die 'cannot generate runtime-po/Makevars'
983
984     # Copy identical files from po to runtime-po.
985     (cd po && cp -p Makefile.in.in *-quot *.header *.sed *.sin ../runtime-po)
986   fi
987 fi
988
989 bootstrap_epilogue
990
991 echo "$0: done.  Now you can run './configure'."
992
993 # Local variables:
994 # eval: (add-hook 'write-file-hooks 'time-stamp)
995 # time-stamp-start: "scriptversion="
996 # time-stamp-format: "%:y-%02m-%02d.%02H"
997 # time-stamp-time-zone: "UTC"
998 # time-stamp-end: "; # UTC"
999 # End: