Import Gnus subtree
[packages] / xemacs-packages / gnus / Makefile
diff --git a/xemacs-packages/gnus/Makefile b/xemacs-packages/gnus/Makefile
new file mode 100644 (file)
index 0000000..e5c29d3
--- /dev/null
@@ -0,0 +1,58 @@
+# Makefile for Packaged Gnus code
+
+# This file is part of XEmacs.
+
+# XEmacs is free software; you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by the
+# Free Software Foundation; either version 2, or (at your option) any
+# later version.
+
+# XEmacs is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE.  See the GNU General Public License
+# for more details.
+
+# You should have received a copy of the GNU General Public License
+# along with XEmacs; see the file COPYING.  If not, write to
+# the Free Software Foundation, Inc., 59 Temple Place - Suite 330,
+# Boston, MA 02111-1307, USA.
+
+VERSION = 2.03
+AUTHOR_VERSION = 5.10.10
+MAINTAINER = Henry S. Thompson <ht@inf.ed.ac.uk>
+PACKAGE = gnus
+PKG_TYPE = regular
+REQUIRES = gnus mail-lib xemacs-base eterm sh-script net-utils os-utils dired \
+       mh-e sieve ps-print w3 pgg mailcrypt ecrypto sasl
+
+CATEGORY = standard
+
+DONTCOMPILE = lisp/dgnushack-xemacs.el lisp/dgnushack.el lisp/lpath.el \
+       lisp/gpg.el lisp/gpg-ring.el lisp/_pkg.el lisp/auto-autoloads.el \
+       lisp/custom-load.el
+
+ELCS = $(patsubst %.el,%.elc,$(filter-out $(DONTCOMPILE),$(wildcard lisp/*.el)))
+
+EXTRA_SOURCES = COPYING $(wildcard lisp/*.upstream) lisp/GNUS-NEWS \
+       $(DONTCOMPILE)
+
+DATA_FILES = $(wildcard etc/sounds/*.au) $(wildcard etc/sounds/*.wav)
+DATA_DEST = sounds
+DATA_1_FILES = etc/smilies/README $(wildcard etc/smilies/*.x?m)
+DATA_1_DEST = smilies
+DATA_2_FILES = etc/gnus/GNUS-README etc/gnus/README etc/gnus/README2 \
+       etc/gnus/README3 $(wildcard etc/gnus/*.[px]?m) \
+       etc/gnus/x-splash
+DATA_2_DEST = $(PACKAGE)
+DATA_3_FILES = etc/gnus-tut.txt
+DATA_3_DEST = $(PACKAGE)
+
+EXPLICIT_DOCS = texi/message.texi texi/gnus.texi texi/emacs-mime.texi
+EXTRA_TEXI_FILES = texi/gnus-faq.texi texi/doclicense.texi
+
+AUTOLOAD_PATH = lisp
+
+PRELOADS = -l dgnushack-xemacs.el -l lpath.el
+
+include ../../XEmacs.rules
+